编程 求大神指导

【问题描述】编写程序,输入x(int类型),计算并输出下列分段函数f(x)的值。要求定义和调用函数sign(x)实现该分段函数。
1 x > 0
f(x) = 0 x = 0
-1 x < 0
【输入形式】在提示“Please input x: ”的下一行输入x的值。
【输出形式】在提示“f(x) = ”后输出f(x)的值
【样例输入】
Please input x:
12
【样例输出】
f(12) = 1

第1个回答  2014-10-31
没有调试,大体就是这样吧
void main()
{
int x = 0;

printf("Please input x:\n");

scanf("%d", x);

if(x > 0)
{

printf("f(%d) = %d\n", x, 1);

}
if(x == 0)

{

printf("f(%d) = %d\n", x, 0);
}

if(x < 0)

{

printf("f(%d) = %d\n", x, -1);
}
}
第2个回答  推荐于2016-07-31
#include<iostream>
using namespace std;

int main()
{
int x;

int result;
cout<<"Please input x:"<<endl;
cin >>x;

if(x>0)

result = 1;

else if(x==0)

result = 0;

else

result = -1;

cout<<"f("<<x<<")="<<result<<endl;
}本回答被提问者和网友采纳
相似回答